You want to protect your site and keep its content safe, right? Of course you do, especially with all these recent security scares going on. Have a read about the new WordPress security update package we are now offering and the ways which it will protect your website from those crafty hackers.

Due to the many well documented online security breaches, (not least of which being the recent scandal involving a Russian gang hacking 1.2 billion usernames and passwords.), we’ve decided to offer a simple WordPress security update package. Your site’s a bit like your home –  you want to protect it to keep its content safe. You wouldn’t just leave the door to your house open for people to break in, right?

The WordPress Security package comprises of two main sections:

1) Update WordPress and all your site’s plugins.

2) Install a raft of additional security measures to really tighten things up and give you peace of mind.

Why do I need to update WordPress?

WordPress claims the crown of having a bigger market share than any other CMS at 53.8%, beating Joomla, Drupal and all other content management systems put together. Millions of website owners have chosen WordPress to power their websites, even websites as huge as ‘The New York Times’.

However, as good as WordPress is, it still needs an update from time to time.

Security

The main reason to update is for security. WordPress regularly releases security updates, so if you’ve not upgraded for a while there’ll be a chink in your site’s armour. Not only could you lose all of your hard work, but relationships built with customers could be ruined, and their personal data stolen. According to WPBeginner, 83% of all hacked WordPress accounts were not updated.

New features

WordPress becomes wiser with old age, creating new features to become even more useful and easier to use. Although, these features can only be gained access to by updating. Ideally an update should occur once every six months, this will make things a lot easier for yourself. If you wait too long and have to then update more than one version at a time you will have to learn about a lot more features at once than if you had just downloaded one version.

Fixing bugs

New updates come with numerous bug fixes, so minor niggles may well be patched with an upgrade to the latest version of WordPress.

Update and Fix plugins

In addition to updating WordPress, all of the plugins within the current content management system will need to be updated. Any seriously out-of-date plugins will be vulnerable to attack, meaning your website may as well have a bulls-eye painted on it for all hackers to see.

Additional security software

As well as updating WordPress the package would also include installing a range of new security based software to make your site as safe as possible going forward.

1) Malware Scanner

This plugin searches your website for any problems; these could be spam, blacklisting, malware, etc. It also provides audit trails which show who has accessed the WordPress account and what actions they have done. It also helps to reset passwords in case your account has already been hacked or infected.

2) BackupBuddy

Another important plugin! This allows you to backup all the data within your WordPress website, in case something were to go wrong. A backup can be scheduled to happen hourly, daily or weekly, depending on how often you update your site. This means that if the worst does happen and your site gets hacked, you can restore it to it’s former glory.

3) Obscure

Changes the URL for the WordPress dashboard area, as well as many other common entrance routes for hackers. This is important as everyone knows the original URL is just www.yoursite.co.uk/wp-admin making it so simple for anyone to access your site’s login. This is only one of the many ways this plugin will obscure any sensitive areas which will ultimately help stop hackers from learning too much about your site.

4) Detect

Your site will also be monitored for any suspicious behaviour, which you will be alerted of straight away via email notifications. This will include changes to site files or any failed login attempts.

5) Enforce strong passwords

This plugin is very simple yet very important, as a weak password is the most vulnerable Security aspect of WordPress. 8% of people on WordPress have been hacked due to a weak password. Using this plugin will force high level users to have a strong password.

Last year 170,000 users accounts were hacked on WordPress sites alone. Now, I’m sure you wouldn’t like to contribute to the number of sites which have been hacked?